Publication d'un "Événement" d'une seule journée

Présentation du Kit Web du CNRS Forums Utilisation du Kit Web CNRS Publication d'un "Événement" d'une seule journée

Mots-clés : ,

15 sujets de 1 à 15 (sur un total de 15)
  • Auteur
    Messages
  • #1797
    Bourgeois Audrey
    Participant

    Bonjour à tous,

    Je ne parviens pas à publier l’un de nos événements, prévu le 9 octobre prochain.
    J’enregistre la date de début : « 09/10/2018 9h00 », et lorsque je veux enregistrer la date de fin « 09/10/2018 17h00 » j’ai le message suivant qui s’affiche : « La date de fin doit être supérieure à la date de début », et impossible de publier l’événement.

    Savez-vous comment contourner ce souci, sans être contraints d’indiquer une mauvaise date ?

    Merci et bon courage à tous

    #1825
    asanogo
    Participant

    déjà, il faut désactiver l’option de saisie de ce champ obligatoire.
    tu vas sur administration puis modifier les pods tu clic sur le pods événement en suite le champs date de fin et tu pourras le décocher l’option obligatoire n’oublie pas d’enregistrer le pods je crois ça devrait passer maintenant

    • Cette réponse a été modifiée le il y a 2 années par asanogo.
    #6790
    Pasqualini Antoine
    Participant

    Bonjour,

    Je viens de rencontrer le même problème et donc pour préciser une solution : On peut tout-à-fait avoir un événement d’une journée. Il suffit de laisser la date avec strictement la même heure. L’heure ne s’affichant pas sur le site, c’est donc un moindre mal.

    Bonne journée,

    #6940

    Bonjour,

    J’ai également le même problème : « La date de fin doit être supérieure à la date de début ». Et bizarrement pas sur tous les évènements, seulement sur quelques-uns. Je ne vois pas la logique. En tout cas, merci pour le conseils, malheureusement, celui de décocher l’option obligatoire du champs « date de fin » ne change strictement rien chez nous… 🙁 Auriez-vous une autre piste éventuellement? Ce serait tout de même pas mal de préciser les horaires pour certains évènements…

    Merci et bonne soirée, Claudia Pichon-Starke

    #7193

    Bonjour et meilleurs voeux à toutes et à tous.

    En ce qui concerne le message d’erreur « La date de fin doit être supérieure à la date de début », nous pensons avoir trouvé la cause :

    Il doit s’agir d’un problème numérique au niveau des horaires. Nous avons eu par exemple deux soutenances le même jour, une entre 9h et 12h et l’autre entre 14h et 17h. Celle de l’après-midi n’a pas du tout posé de problème au niveau de la saisie des horaires, le système a parfaitement accepté. Quant à celle du matin, le système bloque et annonce donc « La date de fin doit être supérieure à la date de début », car pour lui, 9 se situe après 12 dans l’échelle numérique. Il comprend probablement « 9(0) » et non « (0)9 ». Du coup, il interprète mal. Ca c’est notre piste au moins.

    C’est tout de même embêtant car les horaires s’affichent sur le site, et c’est très bien comme ça, c’est une information importante.
    Donc, comment résoudre ce problème?

    Bonne journée !

    #7200
    Seguinot Christophe
    Participant

    Je ne comprends pas, sur mon installation originale, avec le kit non débogué, je parviens à créer un événement qui ne respecte pas date de début < date de fin; ce qui m’affiche pour cet événement:
    Event date: 2019/1/10 14 h 00 – 11 h 00
    et je ne parviens pas à reproduire l’erreur mentionné au dessus (événement de 9 à 12 )!

    #7201

    Oui, c’est étrange… Pourtant, il semble y avoir d’autres personnes avec le même problème (cf. le message initial de Audrey Bourgeois).

    L’agenda est un élément « 100% Kit », non? Cela peut être sinon une erreur WordPress? Je ne saurais même pas où chercher…!

    #7864
    Loirat Mireille
    Participant

    Bonjour,
    Je relance ce sujet car je rencontre le même problème, notamment pour des événements prévus sur 2 ou trois jours. J’ai observé la même chose que Claudia Pichon-Starke, à savoir qu’il doit s’agir d’un problème numérique, mais je ne m’explique pas pourquoi, pour un événement qui doit avoir lieu du 11 au 13 juin, le CMS indique une erreur même lorsque je règle les horaires à 0.
    Quelqu’un a-t-il trouvé une solution depuis janvier?

    Merci d’avance, et bonne fin de journée!

    #7901

    Bonjour, Quelqu’un a-t-il (elle) trouvé une solution pour les champs « date de début » et « date de fin » dans le pod « évènements »? Je suis obligée d’ignorer l’heure, sinon l’évènement est faux et ne s’affiche pas sur l’agenda car le système ne comprend pas comment 09:00 peut être devant 13:00… 🙁 Il affiche une erreur car il comprend apparemment « 9 » devant « 13 » dans l’ordre numérique, donc ça na va pas…

    Pour ceux et celles qui n’ont pas ce problème-là, qu’est-ce que vous avez configuré sous « Administration » -> « Modification de pods » -> « Pod évènement »?

    Merci et bon WE,
    Claudia Pichon-Starke

    #7911
    Badin Flora
    Participant

    Bonjour,
    Même en mettant vide et en enlevant l’obligation d’avoir la date de fin, il y a toujours le problème.
    Est ce que ce dernier a été résolu ?
    Merci

    #7912

    Bonjour, ça fait presque un an et demi que nous avons ce problème qui est vraiment très pénible, et personne ne peut aider. Par ailleurs, ce n’est pas le seul bug non plus. C’est assez désespérant…

    Bonne journée, Claudia

    #7927

    Bonjour à tous et à toutes,

    La solution que nous avons trouvée dans notre labo est la suivante. (nous sommes en train de passer sous le kit CNRS pour le site d enotre unité)

    La vérification (buggée) sur la comparaison entre dates se trouve dans le fichier : admin_script.js (dans le dossier du thème : dossier js > admin_scripts.js)
    Solution : mettre en commentaire avec // (ou supprimer) les lignes 7 à 19 (qui correspondent au test de validation des champs date)
    Résultat 1 : on peut créer un événement sur une seule journée.
    Résultat 2 : le test sur la date (heure de fin supérieure à la date de début) est tout de même géré par WordPress : on a un message d’erreur si on se trompe.

    Bien cordialement,

    Thierry Buquet

    #7931

    Bonjour et un grand merci pour votre aide ! Ca fonctionne merveilleusement bien! C’était un bug très handicapant et j’aurais été incapable de trouver la source du problème!!! Heureusement, il y a au moins ce forum! 😉

    Bonne journée, Claudia

    #7932
    RAFII NEJAD Poupak
    Participant

    Bonjour à toutes et à tous, bonjour Thierry,
    Je suis également en train de refaire le site du labo. Même problème !
    Merci pour les pistes proposées par les uns et les autres.
    J’ai tout essayé (y compris la mise en commentaire de admin_script.js) mais ça ne marche toujours pas.
    Est-ce qu’il y a une histoire de cache à vider ?!
    Merci d’avance pour vos lumières.

    Bonne journée
    Poupak

    #7944
    Pasqualini Antoine
    Participant

    Bonjour,

    Si jamais le problème est encore d’actualité il y a aussi un souci avec le réglage des champs horodatage d’un événement. Et de mon côté la mise en commentaire ne suffisait pas non plus. Dans les réglages du POD evenement j’ai donc modifié les champs date/heure en ne gardant que la notion de date. Conséquence =
    – cela fonctionne
    – plus d’heure affichée (on ne l’utilisait pas, donc…)
    – dans l’admin > evenement les dates s’affichent au format Américain (Attention)

    Bonne journée,

15 sujets de 1 à 15 (sur un total de 15)
  • Vous devez être connecté pour répondre à ce sujet.