erreur 404

Mots-clés : ,

15 sujets de 1 à 15 (sur un total de 20)
  • Auteur
    Messages
  • #926
    dgirod
    Participant

    Bonjour,
    nous avons installé le nouveau kit CNRS sur un serveur local. Dans notre installation, nous n’arrivons pas à afficher les pages du site. Pour toutes les pages nous avons une erreur 404. Pouvez-vous nous expliquer à quoi cela tient ?
    Cordialement,
    Dominique Girod

    #939
    Mangin Lydia
    Participant

    Bonjour,

    Il vous suffit d’aller dans la section Réglages -> Permaliens puis sélectionner une autre valeur (simple, numérique…) enregistrer les modifications puis reconfigurer la valeur désirée.

    Cordialement,
    Lydia Mangin

    #1027
    Chalvignac Greg
    Participant

    Bonjour, je viens d’essayer, cela ne change rien.

    #1070
    Jybaz
    Participant

    Bonjour,

    Dans mon cas, c’était un problème de configuration Apache :

    Il fallait activer le module mod_rewrite et faire en sorte que le .htaccess soit pris en compte en mettant le « AllowOverride All »
    (J’avais remarqué que pour le réglage des Permaliens, en choisissant le « mode simple » cela fonctionnait et avec ce réglage, le .htaccess est vide tandis qu’ une règle de redirection y est ajoutée avec le réglage par défaut du kit).

    Cordialement,

    Jean-Yves

    #1104
    GOUTEYRON Laurent
    Participant

    Merci Jybaz, ça corrige parfaitement le problème …

    #1121
    dgirod
    Participant

    Bonjour,
    le fait d’avoir modifié le réglages de permaliens modifie effectivement les liens dans les menus. Par contre lorsqu’on clique sur « en savoir plus », l’erreur subsiste. Nous avons modifié la configuration Apache comme indiqué ci-dessus mais ça ne change rien. Est-ce qu’il y a autre chose à modifier ?
    Cordialement,
    Dominique

    #1158
    Chalvignac Greg
    Participant

    J’ai également modifié le fichier .htaccess comme suit :
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    Ainsi que le fichier /etc/apache2/sites-available/000-default.conf comme cela :
    <VirtualHost *:80>
    # The ServerName directive sets the request scheme, hostname and port that
    # the server uses to identify itself. This is used when creating
    # redirection URLs. In the context of virtual hosts, the ServerName
    # specifies what hostname must appear in the request’s Host: header to
    # match this virtual host. For the default virtual host (this file) this
    # value is not decisive as it is used as a last resort host regardless.
    # However, you must set it for any further virtual host explicitly.
    #ServerName http://www.example.com

    ServerAdmin webmaster@localhost
    DocumentRoot /var/www/
    <Directory />
    AllowOverride All
    Options Indexes FollowSymLinks
    </Directory>
    # Available loglevels: trace8, …, trace1, debug, info, notice, warn,
    # error, crit, alert, emerg.
    # It is also possible to configure the loglevel for particular
    # modules, e.g.
    #LogLevel info ssl:warn

    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined

    # For most configuration files from conf-available/, which are
    # enabled or disabled at a global level, it is possible to
    # include a line for only one particular virtual host. For example the
    # following line enables the CGI configuration for this host only
    # after it has been globally disabled with « a2disconf ».
    #Include conf-available/serve-cgi-bin.conf
    </VirtualHost>

    Rien n’y fait. Je suis sur une VM Debian 9 x64

    #1161
    Jybaz
    Participant

    Bonjour Greg,

    Le module Apache mod_rewrite est-il activé ? (pour l’activer : sudo a2enmod rewrite)

    Cordialement,

    Jybaz

    • Cette réponse a été modifiée le il y a 2 années et 2 mois par Jybaz.
    #1180
    Dolmazon Thomas
    Participant

    Merci beaucoup cela fonctionne correctement en activant le module rewrite.
    Bonne continuation,

    Thomas

    #1183
    Chalvignac Greg
    Participant

    Bonjour Jybaz, le module est déjà activé :
    root@wwwpress:~# a2enmod rewrite
    Module rewrite already enabled

    #1186
    Jybaz
    Participant

    Bonjour Greg,

    Je viens de m’apercevoir de ce commentaire dans ton fichier de conf apache et si je comprends bien il suffirait que tu renseignes la directive Servername.
    Sinon quel liens sont présents dans le répertoire /etc/apache2/sites-enable/ ?

    # The ServerName directive sets the request scheme, hostname and port that
    # the server uses to identify itself. This is used when creating
    # redirection URLs. In the context of virtual hosts, the ServerName
    # specifies what hostname must appear in the request’s Host: header to
    # match this virtual host. For the default virtual host (this file) this
    # value is not decisive as it is used as a last resort host regardless.
    # However, you must set it for any further virtual host explicitly.
    #ServerName http://www.example.com

    #1187
    Chalvignac Greg
    Participant

    J’ai modifié la directive Servername comme le nom de mon site.

    Dans /etc/apache2/sites-enable/ j’y trouve :
    000-default.conf

    Il s’est modifié en même temps (normal) que 000-default.conf dans /etc/apache2/sites-available.

    Je viens d’essayer de recharger les liens permanents en changeant les types de liens, ça ne change rien.

    Apache est en version 2.4.25. Quelle version utilisez vous? Peut-être une incompatibilité.

    #1190
    Jybaz
    Participant

    Greg,

    As tu vraiment fixé la directive Servername ? (en retirant le caractère # devant)
    As-tu relancé Apache pour que la modification soit prise en compte : service apache2 reload ?

    #1191
    Chalvignac Greg
    Participant

    <VirtualHost *:80>
    # The ServerName directive sets the request scheme, hostname and port that
    # the server uses to identify itself. This is used when creating
    # redirection URLs. In the context of virtual hosts, the ServerName
    # specifies what hostname must appear in the request’s Host: header to
    # match this virtual host. For the default virtual host (this file) this
    # value is not decisive as it is used as a last resort host regardless.
    # However, you must set it for any further virtual host explicitly.
    ServerName http://wwwpress.lspm.***

    (étoiles remplacent la fin du DN)
    Oui, j’ai lancé un apache2 restart même. Je viens de lancer un reload au cas où, même chose

    #1194
    Jybaz
    Participant

    Greg, je crois avoir trouvé la solution à ton problème que j’ai reproduis chez moi donc il faudrait que tu remplaces la section

    <Directory />
    AllowOverride All
    Options Indexes FollowSymLinks
    </Directory>

    par :

    <Directory />
    Options FollowSymLinks
    AllowOverride None
    </Directory>

    pour des raisons de sécurité et que tu rajoutes à la suite cette nouvelle section (qui résoudra ton pb de redirection)

    <Directory /var/www/>
    Options FollowSymLinks MultiViews
    AllowOverride All
    Require all granted
    </Directory>

    Je te conseille aussi de te documenter sur Apache et de revoir complètement ta conf, c’est fondamental pour l’hébergement d’un sites Web ( pour protéger le serveur de production et l’accès aux données confidentielles sans parler de piratage).
    Le plus simple est parfois de se faire héberger …

    Bien cordialement,

    Jean-Yves

15 sujets de 1 à 15 (sur un total de 20)
  • Vous devez être connecté pour répondre à ce sujet.