Répondre à : Erreur liée au plugin "Polylang"

Présentation du Kit Web du CNRS Forums Installation du Kit Web CNRS Erreur liée au plugin "Polylang" Répondre à : Erreur liée au plugin "Polylang"

#6516

bonjour @Anonyme

cela reste, meme apres l’installation:

l’installation la montre temporairement, puis la masque apres refresh (tres rapide, on peut ne pas la voir: (1) ? ).

– lors de l’installation, erreur du type Invalid argument supplied for foreach() in <votre-site>\wp-content\plugins\polylang\include\model.php on line 100 etc…
– ensuite: ex avec <votre-site>/le-laboratoire/fonctionnement, ca se traduit par si on remet ini_set(« display_errors », 1);
Warning: array_merge(): Argument #1 is not an array in …wp-content/plugins/polylang/include/filters.php on line 157

–> légère correction à faire dans <theme-enfant>\template-parts\content-page.php :


            $args = array(
                'sort_order' => 'asc',
                'sort_column' => 'post_title',
                'hierarchical' => 1,
                'exclude' => array(get_the_ID()), <<<
                'include' => array(), <<<
                'meta_key' => '',
                'meta_value' => '',
                'authors' => '',
                'child_of' => 0,
                'parent' => $post->post_parent,
                'exclude_tree' => array(), <<<
                'number' => 3,
                'offset' => 0,
                'post_type' => 'page',
                'post_status' => 'publish'
            );

ensuite, tout est ok avec ce template ! 🙂

———————————————————————————
load.php de wordpress :

<em><strong>(1)  </strong>	if ( defined( 'XMLRPC_REQUEST' ) || defined( 'REST_REQUEST' ) || ( defined( 'WP_INSTALLING' ) && WP_INSTALLING <<<< ) || wp_doing_ajax() ) {
		<strong>@ini_set( 'display_errors', 0 ); <<<</strong>
	}</em>