Page blanche dans le navigateur lors de l'installation de la base phpmyadmin

Présentation du Kit Web du CNRS Forums Installation du Kit Web CNRS Page blanche dans le navigateur lors de l'installation de la base phpmyadmin

Ce sujet a 2 réponses, 2 participants et a été mis à jour par  DIDIER Mélody, il y a 2 mois et 2 semaines.

3 sujets de 1 à 3 (sur un total de 3)
  • Auteur
    Messages
  • #7074

    DIDIER Mélody
    Participant

    Bonjour,

    J’ai installé le fichier sql dans ma base de donnée phpmyadmin, et depuis, j’ai une page blanche dans mes navigateurs lorsque je vais sur l’adresse du site.
    Voici la réponse donnée par mon service informatique :

    Soucis dans ton code, voici le message d’erreur:

    [Tue Dec 18 15:12:50.094011 2018] [:error] [pid 9702] [client 172.20.133.5:53099] PHP Fatal error: Uncaught Error: Call to a member function field() on null in /var/www/html/www-dev/wp-content/themes/cnrswebkit/inc/inc-pages-functions.php:875\nStack trace:\n#0 /var/www/html/www-dev/wp-content/themes/cnrswebkit/functions.php(438): require()\n#1 /var/www/html/www-dev/wp-settings.php(426): include(‘/var/www/html/w…’)\n#2 /var/www/html/www-dev/wp-config.php(94): require_once(‘/var/www/html/w…’)\n#3 /var/www/html/www-dev/wp-load.php(37): require_once(‘/var/www/html/w…’)\n#4 /var/www/html/www-dev/wp-blog-header.php(13): require_once(‘/var/www/html/w…’)\n#5 /var/www/html/www-dev/index.php(17): require(‘/var/www/html/w…’)\n#6 {main}\n thrown in /var/www/html/www-dev/wp-content/themes/cnrswebkit/inc/inc-pages-functions.php on line 875

    Les messages d’erreur se trouvent dans /var/log/apache2/error.log

    Est-ce que quelqu’un peut m’aider à corriger ?

    #7143

    Seguinot Christophe
    Participant

    Bonjour

    l’erreur Call to a member function field() on null se produit ici

    if (function_exists('pods')) {
        $cnrs_global_params = pods('reglage_du_theme');
    }
    
    if (!$cnrs_global_params->field('commentaires_actifs')) {

    Cela indique que $cnrs_global_params est null donc que WordPress ne trouve pas les paramètres du kit CNRS dans la base de données; ce qui ne devrait pas se produire!
    Perso, je vérifierai en premier si:
    – le préfixe des tables de WP incluses dans le fichier sql correspond au préfixe déclaré dans le fichier config.php? (ce qui se produit uniquement si on ajoute les tables de la base de données à une version préinstallées de WordPress, mais pas quand on installe le kit!)
    par défaut, on a $table_prefix = 'w9p8MmNkS5ng_';

    Question: est ce que dans la partie admin (www…./wp-admin/edit.php?post_type=page) , les pages du kit CNRS sont présentes?
    -Si non, la base de données du kit n’est pas chargée.

    #7154

    DIDIER Mélody
    Participant

    Bonjour,

    Merci de votre retour ! Il y avait, en effet, quelques erreurs dans les fichiers que vous avez ciblé. C’est maintenant résolu !

    Un très grand merci pour votre aide précieuse !

3 sujets de 1 à 3 (sur un total de 3)

Vous devez être connecté pour répondre à ce sujet.