Migration site de developpement -> production: problème d'URL

Présentation du Kit Web du CNRS Forums Installation du Kit Web CNRS Migration site de developpement -> production: problème d'URL

Ce sujet a 1 réponse, 1 participant et a été mis à jour par  Seguinot Christophe, il y a 4 mois et 3 semaines.

2 sujets de 1 à 2 (sur un total de 2)
  • Auteur
    Messages
  • #1628

    Seguinot Christophe
    Participant

    Bonjour

    Je teste mon site en préproduction. Je butte sur le problème d’URL suivant: la page d’accueil conserve son ancienne URL (domaine de test).
    J’ai procédé comme pour une installation, j’ai activé « domain name changer » et l’ai fait tourner (il avait détecté le changement de domaine et m’a proposé de faire les changements dans les tables).
    J’ai par ailleurs régénéré mes menus (au cas ou), et aussi régénréré mes permaliens
    Chose bizarre, le permalien erroné de la page d’accueil n’est pas modifiable. J’ai même tenté de modifier la page d’accueil, mais le permalien de l’ancienne (vraie) page d’accueil reste non modifiable!!
    Il me reste plus que la modifications en dur dans les tables (certaines tables ne semblent pas prise en compte par « domain name changer » mais comme cela correspond à des grandeurs sérialisées ce n’est pas trivial!!

    #1633

    Seguinot Christophe
    Participant

    Le problème résulte de l’utilisation d’une page « statique » qui pointe vers le lien déclaré dans le menu / Administration / Réglages/ Lecture.
    Pour une raison inconnue, il n’est pas possible de modifier cette page ou son lien après migration du site sur un nouvel hébergement!

    Solution de contournement:
    – dans le menu / Administration / Réglages/ Lecture sélectionner « La page d’accueil affiche » « Les derniers articles » valider
    – puis sélectionner à nouveau « Une page statique » que vous sélectionnez

    Résolu!

2 sujets de 1 à 2 (sur un total de 2)

Vous devez être connecté pour répondre à ce sujet.