Bug permaliens? Oups ! Cette page est introuvable.

Présentation du Kit Web du CNRS Forums Utilisation du Kit Web CNRS Bug permaliens? Oups ! Cette page est introuvable.

Mots-clés : 

Ce sujet a 3 réponses, 4 participants et a été mis à jour par  Deniaud Cyril, il y a 2 mois et 3 semaines.

4 sujets de 1 à 4 (sur un total de 4)
  • Auteur
    Messages
  • #1135

    Seguinot Christophe
    Participant

    Bonjour

    Mon site de test fonctionnait correctement jusqu’à ce que je mette en place mon menu (secondaire) à 3 niveaux et que je le teste avec les pages importées du site SPIP.
    Soudainement j’obtiens sur la plupart de mes pages le message « Oups ! Cette page est introuvable. ».

    En modifiant le réglage des permaliens j’observe le fonctionnement curieux suivant:

    • URL « simple » : les URL sont effectivement simple, menu fonctionnel
    • URL « nom de l’article » : les URL prennent en compte le nom de l’article dans les menus, la plupart des liens de menu génère l’erreur « Oups ! Cette page est introuvable. ».
    • tous les autres réglages d’URL: les URL sont identiques quelque soit le réglage. par exemple les URL « numériques » ne sont pas numériques. Par contre les liens de menus deviennent fonctionnels

    J’en conclus qu’il y a probablement un bug dans la gestion des permaliens, ou une subtilité que je n’ai pas comprise.

    #1339

    Viala Francoise
    Participant

    Bonjour
    J’ai aussi un problèmes avec les permaliens… mes liens ne marchent que si j’active le lien en mode de réglage « simple » alors que j’aimerai mettre avec « nom de l’article »…
    j’ai essayé en regardant sur le net de modifier le .htaccess mais il était bon comme indiqué sur ce site ( https://thrivethemes.com/tkb_item/resolve-wordpress-404-error-permalink-change/ )
    Nous avons aussi essayé en lançant le mode « a2enmod rewrite » sur apache comme indiqué sur ce lien : https://wpfr.net/support/sujet/probleme-permaliens-404-2/ mais là aussi ça ne résout pas notre problème.

    Avez vous une idée ??
    Merci par avance
    Françoise

    #1346

    Chalvignac Greg
    Participant

    Bonjour, vous avez de la chance, pour ma part cela n’a jamais fonctionné (voir sujet http://kit-web.cnrs.fr/forums/topic/erreur-404/) depuis que j’ai installé la solution.
    J’essaye actuellement avec Ubuntu voir ce que cela donne.
    Bon courage

    #1620

    Deniaud Cyril
    Participant

    Bonjour,

    Pour nous également les permaliens ne fonctionnent pas.
    L’installation a été ralisée sur une Linux Debian. Ces points ont été vérifiés un par un :
    – le serveur web a les droits de lecture écriture sur le fichier .htaccess (groupe www-data propriétaire du fichier et droits 660). Evidemment www-data « arrive » jusqu’au fichier htaccess, sinon le site ne s’afficherait pas du tout.
    – La directive « Allowoverride All » est bien présente dans la déclaration du répertoire racine du site dans la configuration Apache
    – Toujours dans Apache, mod_rewrite est activé

    Comme pour les autres béta-testeurs, seul le choix « Simple » fonctionne, toutes les autres options conduisent à « Oups ! etc… ».

    En dernier ressort, j’ai suivi les indications de WordPress en écrivant à la main les directives qui vont bien dans le fichier .htaccess, et cela n’a absolument aucun effet. Tout autre choix de Permalien que « Simple » conduit à « Oups ! Tabernacle ! L’a’pin trouvé l’pôge là… »

4 sujets de 1 à 4 (sur un total de 4)

Vous devez être connecté pour répondre à ce sujet.